Professional Geek
RSS icon Email icon Bullet (black)
  • Problems With Sonicwall and Multiple PPPoE Connections

    Posted on March 17th, 2015 Andy Parkes 3 comments

    Now there’s an attention grabbing headline if ever I saw one!

    Just a quick reminder post in case I come across this again or it helps anyone else.

    We did some work for a client recently to replace their firewall with a shiny new Sonicwall NSA 2600.

    In the days following the replacement we were getting reports of connectivity problems.

    Inbound connections to the remote desktop server were dropping out and a web application they use was suffering from time outs.

    Even pings out to various servers on the internet were giving us results that showed something wasn’t quite right.

    image

    The only thing that had changed was the firewall so we put the old one back in and everything returned to normal.

    This meant I spent a few hours going through each setting. We’d set the new firewall up exactly the same as the old one but there was clearly buy ativan online reviews something different between the two.

    We initially narrowed it down to a problem with the PPPoE connections.

    This particular setup had three WAN connections, two of which were PPPoE. The other connection didn’t have any problem at all. 

    After liaising with Sonicwall support we got to the bottom of it.

    There is a setting in the WAN connection that needs to be enabled that wasn’t available with the previous firewall.

    “Allow duplicate MAC addresses”

    image

    There is ONE article on the Sonicwall knowledgebase that mentions this setting.

    The scenario discussed in the article doesn’t fit our setup though.

    We weren’t using load balancing, both connections had a different default gateway and traffic was flowing across both connections, just not very well.

    However, changing the setting worked. Turning it back off caused the issue to reoccur.

    It’s been fine now for almost a month, 

    The following two tabs change content below.
    Andy Parkes is Technical Director at Coventry based IT support company IBIT Solutions. He is also Microsoft Partner Area Lead for 2012-2013 and coordinates AMITPRO which is a peer group for IT Professionals in the Midlands area. He also isn't a fan of describing himself in the third person.

    Latest posts by Andy Parkes (see all)

     

    3 Responses to “Problems With Sonicwall and Multiple PPPoE Connections”

    1. Hi Andy,

      We did the same fix but when we moved to 6.2.5 we are again experiencing the same problem before.

      Have you tried the latest firmware?

    2. Hi Nap,

      Haven’t upgraded that firewall to 6.2.5 just yet

      Will take a look

      Thanks
      Andy

    3. Hi Nap

      Upgraded to 6.2.6 this week (eventually! Needed to organise with the customer)

      It’s been a few days and we’ve had no problems so far

    Leave a Reply