Sonicwall Firewall & Exchange 2000 OWA

We have a customer who is trying to squeeze every last breath from their SBS 2000 installation.

We have demonstrated the benefits of SBS 2003 but they dont want to spend the cash (yet!)

Anyway, after being told about Outlook Web Access hundreds of times we got asked the question

“can i access my email away from the office?”

Since they had a new firewall recently we needed to configure the correct ports.

So we opened up

HTTP (80), HTTPS (443), IMAP4 (143) and IMAP4TLS (993)

Thankly OWA 2003 is far easier!

Anyway we decided to log in and test it before we let them use it.

Prompted for login details as expected,

Page loads the OWA interface

Right hand pane says “loading” and the folder list is just an hourglass.

We waited a few minutes but nothing happened. I went back and double checked the ports were correct (useful MS article here)

I decided to check the firewall logs and thats when i realised the problem

The Sonicwall firewall has an Intrusion Prevention Service (IPS) module. It had flagged up a couple of alerts

IPS Prevention Alert: WEB-IIS MS00-058 View Script Source Via Translate Header, SID: 1339, Priority: Low 

IPS Prevention Alert: WEB-MISC SELECT FROM Attempt (possible SQL Injection), SID: 1827, Priority: Low

The firewall had deemed that accessing OWA was an threat to the network.

I double checked that the SBS was fully patched and changed the settings from “block” to “alert”, it lets it through but at least i’ll know if any unauthorised access is attempted

I’m not entirely happy about this as a solution but OWA duly worked once i’d changed the settings

As soon as they make the move to SBS 2003 i’ll put the settings back

Hope this is of use to someone!

The following two tabs change content below.
Andy Parkes is Technical Director at Coventry based IT support company IBIT Solutions. Formerly, coordinator of AMITPRO and Microsoft Partner Area Lead for 2012-2013. He also isn't a fan of describing himself in the third person.

Latest posts by Andy Parkes (see all)

2 thoughts on “Sonicwall Firewall & Exchange 2000 OWA

  • I had the same problem with OWA on Exchange 2003 behind a sonicwall pro 2040 with IPS fully enabled; I had to disable some of the low priority blocking. I also had the same problem when a user tried to attach a large number of recipients to an e-mail generated in OWA.

  • Thanks for the comment Travis

    To be honest i haven’t had any trouble with Exchange 2003 (yet)

    There are known issues with meeting requests and IPS though

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.